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Process Control:  

SPM Image Analysis/Processing Software
When you initially power up SPMLab, the software enters the Image Analysis/Processing module.  The software processes files created with SPMLab software, files provided by ProScan software (with the extension .hdf), and other binary files.  The software processes in any of three lower level modes: Display, Processing, and Analysis.  In Display mode, functions such as background subtraction, contrast and brightness, 3D display, and palette editing are controlled.  Visualization of the image is enhanced without affecting the data.  In Processing mode, image, curvature, leveling, convolutions, arithmetic processing, filtering, etc. are all handled.  In the Analysis module, the image is analyzed with various statistical and measurement routines, such as line profile, peak and valley analysis, particle and grain analysis, and step measurement.
The following provides a summary description of all the functions on the Image Analysis/Processing Menu and toolbar, as shown in Figure I.
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Figure I.  Image Analysis/Processing Module Main Screen.
Image Analysis/Processing Menu Items

The Image Analysis/Processing menus and toolbar are shown in Figure II.  Note that the menu options and toolbar buttons displayed depend on the options you are using.  This manual describes the menu options and toolbar buttons that are standard to all systems.  When you order an option, such as Grain and Particle Analysis, the accompanying documentation describes the menu options and icons specific to that option.
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Figure II.  Image Analysis/Processing Menu and Toolbar.
The File Menu

The File menu, shown in Figure III, allows you to access the File Manager, as well as

save, export and import images. The File menu items are described briefly in Table I.
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Figure III.  File menu.
Table I.  The File menu items.
	
	

	File Manager
	Opens the File Manager dialog box, which displays all files which have the SPMLab and AutoProbe ProScan (.hdf) file formats.  Standard file management tools are accessible, such as Delete, Copy, Browse, etc. This function can also be accessed by clicking on the [image: image4.bmp] button on the toolbar.



	Save As
	Opens the Save As dialog box, allowing you to save the currently selected image in the SPMLab format. This function can also be accessed by clicking on the [image: image5.bmp] button on the tool bar.



	
	IMPORTANT: After applying any display functions to a scan image, it is strongly recommended that you save the processed image under a new file name. This ensures that a copy of the original scan data will always be available, unchanged by any process or display functions.



	Export
	Opens the Export dialog box, which saves the selected data in the ASCII text format (.txt), for use with other applications. The feature allows you to export graphs, scan images, oscilloscope displays, etc.  This function is not available for all data.



	Import
	Opens the Import Data dialog box, which allows you to import DBOSS SPM files and other binary files for processing in the Image Analysis/Processing module. Files can also be converted to the standard SPMLab data file format.



	Exit
	Exits SPMLab, after prompting you to save any unsaved data.


The Edit Menu

The Edit menu, shown in Figure IV provides access to the editing tools, which are described briefly in Table II.
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Figure IV.  The Edit menu.
Table II.  The Edit menu items.
	Screen Edit
	Opens the Screen Editor module, which enables annotations, moving of text and images on the screen, printing, and saving the screen or portions of the screen to various output file formats for presentations, export to other image processing packages, etc.



	Data Edit
	Opens the Data Edit tool bar, which provides four tools for basic data (image) editing: area editing, line removal, glitch removal, and step removal.



	Normalize Z
	Stretches the image Z data to half of the full Z data range

(655530/2). If smoothing is applied, all data will be interpolated

between the available data points.


The Buffers Menu

When processing any image in the Image Analysis/Processing module, each successive version of the image is stored in the buffer array (to a maximum of six).  The Buffers menu, shown in Figure V provides access to functions that allow access to the images in the array, as well as the ability to duplicate and delete the images.  The Buffers menu items are described briefly in Table III.
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Figure V.  The Buffers menu.
Table III.  The Buffer menu items.
	Select
	Opens the Image Buffers dialog box, which simultaneously displays all images currently in the buffer array. From this dialog box, any image can be imported to a new window, saved, deleted, or duplicated.



	Next
	Selects the next image in the buffer array. This function is disabled if there are no more images in the array sequence. This function can also be accessed by clicking on the [image: image8.bmp] button on the tool bar.



	Previous
	Selects the previous image in the buffer array. This function is

disabled if there are no previous images in the array sequence. This function can also be accessed by clicking on the [image: image9.bmp] button on the tool bar.



	Duplicate
	Duplicates the currently selected image and adds the duplicate to the buffer array. This function can also be accessed with the Image Buffers dialog box by selecting Buffers [image: image10.bmp]Select.



	Delete
	Deletes the currently selected image. This function can also be

accessed with the Image Buffers dialog box by selecting

Buffers [image: image11.bmp]Select.




The Display Menu
The Display menu, shown in Figure VI, provides access to the Image Analysis/Processing functions that allow you to determine how your image will appear, including contrast and brightness functions, color palettes, color distribution, 3D positioning, etc. The Display menu items are described briefly in Table IV.
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Figure VI.  The Display menu.
Table IV.  The Display menu items.
	Contrast &

Brightness
	Opens the Contrast & Brightness dialog box, which provides realtime, 0-100% contrast and brightness slider controls for the selected image.



	Palettes
	Opens the Palettes dialog box, which provides access to the color palettes library. Any palette’s effect on an image can be viewed before accepting. This function can also be accessed by clicking on the [image: image13.bmp] button on the tool bar.



	Palette Editor
	Opens the Palette Editor dialog box, which allows real-time editing of the RGB values of the selected color palette’s histogram.



	2D Color Editor
	Opens the 2D Color Mapping dialog box, which allows color distribution and/or sharpness editing for the Pseudo 2D and True 2D modes. Using the dialog box in the Pseudo Color mode allows editing of sharpness, as well as height vs. slope color distribution for the image, to be applied when Pseudo 2D is selected (8-bit graphics/256 color mode). Using the dialog box in the True Color mode allows editing of the image's sharpness value, to be applied when True is selected (16- or 24-bit graphics mode).



	2D Color
	Allows you to choose Pseudo 2D and True 2D. Pseudo 2D applies the height vs. slope, sharpness, and color distribution settings selected in the 2D Color Mapping dialog box. This option is available for 8-, 16-, or 24-bit color graphics configurations. True 2D applies the sharpness setting selected in the 2D Color Mapping dialog box. This option is only available in 16- or 24-bit color graphics configurations.

Note: The Pseudo 2D and True 2D color menu options will be disabled until your image has had shading applied. The True 2D menu option will be disabled unless your graphics configuration is set to either the 16- or 24-bit color mode.



	Shading
	Opens the Shading dialog box, which enables you to shade the image based on a simulated light source. The dialog box allows the automatic positioning of a left or right light source, or user-defined vector positioning of the light source. The automatic left/right lightsource shading can also be accessed by clicking on the [image: image14.bmp] or [image: image15.bmp] buttons on the tool bar, respectively.



	Histogram
	Opens the Histogram dialog box, which displays the data histogram for the selected image and enables you to edit the image’s color histogram. You can apply the edited histogram to the whole image or a portion of the image. This function can also be accessed by clicking on the [image: image16.bmp] button on the tool bar.



	Equalization
	Redistributes the data histogram across the color palette so that an equal amount of data is applied to each color.



	Color Mapping
	Opens the Color Mapping dialog box, which enables you to edit the RGB distribution of the color palette applied to the currently selected image. The edited color palette can then be applied immediately and/or saved to the palette library, which is accessed by selecting Display [image: image17.bmp]Palettes.



	3D Graphic
	Opens the Graphic dialog box, which allows 3D user-defined positioning of the image display-angle. This function can also be accessed by clicking on the [image: image18.bmp] button on the tool bar.




	Scale 1:1
	Reverts a scaled (up or down) top-view image to a 1:1 ratio, where one pixel is equal to one data point.




	Zero Set
	Opens the Zero Set dialog box, which enables you to define a zero set point for the image’s Z data. You can then use two different color palettes to display the data above and below the zero set point.



	Zero Set Off
	Cancels the zero set point and dual palettes selected with the Zero Set function, reverting the image to its original settings.



	Scale XY
	Opens the XY Scale dialog box, which enables you to change the image’s X,Y scale setting and measurement unit. Generally, this function is used to round the scale values.

Note: No mathematical conversion takes place when changing the image’s X,Y scale or measurement unit, i.e., for a 12 μm x 12 μm image, changing the measurement unit to Å will result in an image that incorrectly lists the X,Y dimensions as 12 Å x 12 Å. You must perform the calculation manually to determine the new X,Y scale based on the new unit, then change XY Scale value accordingly.



	Common Color

Bar
	Opens the Common Color Bar dialog box, which provides two

methods of applying common parameters to different images:

-The Common Color Bar dialog box provides the ability to compare up to six similar images by applying a common Z range to all of them.

-The Advanced Common Color Bar dialog box provides a histogram of each image currently open. Offset, Z max, and Z min can then be set individually for each histogram, and a common range setting can be applied. For a full description of this



The Process Menu

The Process menu, shown in Figure VII, provides access to functions that fall into the category of operations that affect the presentation and interpretation of your data.  Image tilt, filtering, zooming, shading, etc. are all Process operations.  The Process menu items are described briefly in Table V.
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Figure VII.  The Process menu.
Table V.  The Process menu items.
	Leveling
	Opens the Leveling dialog box, which offers a variety of automatic and advanced leveling routines, designed to remove curvature and/or tilt from an image. First-order 2D (plane subtract) leveling can be performed automatically by clicking on the [image: image20.bmp] button on the tool bar.



	Background
	Opens the Background dialog box, enabling you to perform background subtraction on an image. Background subtraction is a user-defined rolling-ball and rolling-arc filtering process used to eliminate an image’s background features, preserving the surface features for analysis.



	System

Background
	Opens the System Background Subtraction dialog box, which is used to calculate and eliminate anomalous instrument/scanner curvature (also called “bow”) from image data. This allows surface feature analysis, assuming a totally flat-bottomed sample.



	Convolution
	Opens the Convolution dialog box, enabling you to apply a pixel-bypixel filtering function to the image, from a standard kernel, a userdefined kernel, or a kernel library. (A kernel is a matrix of numbers used to modify the pixel from its center.)




	Filter
	Opens the Filter dialog box, which enables you to filter the Z data in an image. The filtering function is set to smooth low-, median-, or high-frequency features, based on user-defined matrix size and Z frequency settings.



	Arithmetic
	Opens the Arithmetic dialog box, which enables you to add, subtract, multiply, or divide two images; or a scaled percentage of the first image with the second image.



	Scale & Zoom
	Opens the Scale & Zoom dialog box, which enables you to choose from a range of pixel resolutions, scaling the image up or down.



	Rotation
	Opens the Rotation dialog box, which enables you to apply a fixed or user-defined rotation to the image.



	1D FFT
	Opens the 1D FFT dialog box, which displays the currently selected image’s power spectrum and enables you to filter the image in either the X, Y, or X and Y directions.



	2D FFT
	Opens the 2D FFT dialog box, which displays the currently selected image’s power spectrum in two dimensions and enables you to configure the filtering with a set of Spectrum editing tools. This function can also be accessed by clicking on the [image: image21.bmp] button on the tool bar.



	Calibration
	Provides access to the Make Coefficients and Load Coefficients options.

Make Coefficients allows you to automatically calculate the coefficients related to scanners (calibration, linearity, etc.) based on a stored image (normally a standard calibration grid image).

Load Coefficients allows you to use the coefficients calculated with the Make Coefficients function and apply them to an arbitrary image, provided both images are scanned under the same conditions.




The Analysis Menu

The Analysis menu, shown in Figure VIII, provides access to the system's array of analysis functions, allowing detailed quantitative examination of the image in a variety of modes.  The Analysis menu items are described briefly in Table VI.

[image: image22.png]Line Measure.
Paak  Valloy Measurs
Line Anlysi.

“Area Analysis >

partcla Analysi.
Grai Analyss.
Gitical Dimension.





Figure VIII.  The Analysis menu.
Table VI:  The Analysis menu items.
	Line Measure
	Opens the Line Measurement dialog box, which enables you to select and compare three line profiles (horizontal, vertical, and/or variable) from the selected image. The generated data includes XYZ location data, point difference, point distance, and angle data.  This function can also be accessed by clicking on the [image: image23.bmp] button on the tool bar.



	Peak / Valley

Measure
	Opens the Peak/Valley Measurement dialog box, which analyzes an image, creating data and histograms representing the peak spacing (the distance between adjacent peaks) and peak angle (the slope between a peak and its nearest valley).



	Line Analysis
	Opens the Line Analysis Setup dialog box, which enables you to perform up to three concurrent cross-sectional line analyses, calculating height, roughness, bearing ratio, and fractal measurements.



	Area Analysis
	Accesses the following Area Analysis modules:



	Roughness
	Opens the Area Standard Roughness dialog box, which calculates and displays the roughness parameters for the entire image or a userdefined portion (exclusive or inclusive).




	Measurement
	Opens the Area Measurement dialog box, which calculates the projected area and surface area of the entire image or the area of a user-defined portion (exclusive or inclusive).



	Fractal
	Opens the 2D Fractal Analysis dialog box, which uses a “lake filling” algorithm to calculate the fractal coefficient for the surface.  It calculates the number of lakes in the image (based on user-defined criteria), then performs a fractal analysis of the image.



	Bearing Ratio
	Opens the 2D Bearing Ratio dialog box, which creates a bearing ratio plot for the selected image. The bearing ratio (percentage of total data appearing above a user-selected Z level) can be calculated for any user-defined point on the plot.



	PS Density
	Opens the Power Spectral Density dialog box, which creates a Power Spectrum for the selected image. The PSD function is defined as the square magnitude of the Fourier transform of the surface. RMS measurements can be calculated for any user-defined pair of points on the plot.



	Particle

Analysis
	Opens the Particle Analysis dialog box, which performs a particle analysis (count, volume, volume histogram, area, perimeter, avg. height, max. height) based on user-defined minimum detectable particle size and Z threshold parameters.



	Grain Analysis
	Opens the Grain Analysis dialog box, which performs a grain analysis (count, volume, volume histogram, area, area histogram, avg. height, max. height) based on user-defined minimum detectable grain size parameters (by slope or Z threshold).



	Critical

Dimension
	Opens the Critical Dimension dialog box, which provides four basic geometric patterns you can use to define and analyze critical dimensions (width, step height, angle, radius, etc.) of any defined area in the selected image.




The Setup Menu

The Setup menu, shown in Figure IX, provides access to acquisition hardware and software configuration information, as well as the Color Settings dialog box.  The Setup menu items are described briefly in Table VII.
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Figure IX.  The Setup menu.
Table VII.  The Setup menu items.
	Scan

Parameters
	Opens the File Info window, which lists the vital data acquisition statistics for the selected image (SPMLab version, stage type, probe type, scan rate, scan direction, etc.). This function can also be accessed by clicking on the [image: image25.bmp] button on the tool bar.



	Screen Colors
	Opens the Color Settings dialog box, which enables you to set various user interface colors for the screen, image, and graphs.



	Preferences
	Opens the Acquisition Preferences dialog box (see page 22).




The Window Menu

The Window menu, shown in Figure X, provides access to the Data Acquisition module and allows control over all windows open in the current interface.  The Window menu items are described briefly in Table VIII.
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Figure X:  The Window menu.
Table VIII.  The Window menu items.
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Image Analysis/Processing Tool Bar

The Image Analysis/Processing tool bar, shown in Figure XI, provides single-click access to some of the most commonly-used functions.  Each button on the toolbar is described below.
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Figure XI.  Image Analysis/Processing toolbar.
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Training necessary:  Safety training and lab review.

Objective: The objective of this lab is to explore and learn to use the Veeco SPMLab image analysis/processing software.
Experiment:  Using provided scans, explore the SPMLab software.  There are a number of menu items in each of the Display, Process, and Analysis menus.  Demonstrate one menu item in each menu totaling three menu items.  Line Measure under the Analysis menu must be one of the three menu items chosen.
All three chosen menu items will require a write-up, which will include:

· How the chosen scan best illustrates the chosen menu item

· A procedure on how you used the menu item starting at opening the menu item

· The before and after images or analysis window with results in view

There will be three separate write-ups total.
A few notes:

· Save often

· Procedures should cover all aspects and variables of the menu item

· Procedures that need explanation must be included

· Anyone should be able to take your procedure and follow them to successfully perform and understand the menu item.

· After images do not have to be perfect.  They need to show the change from the menu item compared to the before image.

Attachments:   

The following must be included in the report in order to receive credit.  These scans should be included in the results section.

· For Display and Process functions, a before and after image of the chosen scan.
· For Analysis functions, the analysis window with results in view.
References:  http://www.veeco.com
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